日別アーカイブ: 2019年12月1日

Flutter, ‘which requires SDK version’ message


Windows の Android Studio で pubspec.yaml に、xml: ^3.6.0 を追加し、dartファイルに import 'package:xml/xml.dart' as xml;を追加すると次のようなエラーメッセージが表示されます。

The current Dart SDK version is 2.5.0.

Because (appname) depends on xml >=3.6.0 which requires SDK version >=2.6.0 <3.0.0, version solving failed.
Running "flutter pub get" in (appname) …
pub get failed (1)

次のコマンドをそれぞれ実行しました。

  • flutter doctor -v
  • flutter upgrade
  • flutter pub get
  • flutter channel master
  • flutter -v
  • flutter upgrade
  • flutter pub get

flutter -vを実行したところ

Checking Dart SDK version...
Downloading Dart SDK from Flutter engine (hash hex?)...
Unzipping Dart SDK...
Building flutter tool...
Running pub upgrade...
Manage your Flutter app development.
が表示されてダウンロードが始まりました。その後エラーメッセージが表示されなくなりました。2019-12-01の時点で xml: ^3.6.0は指定できないので xml: ^3.5.0を指定することになりました。
Because every version of flutter_test from sdk depends on xml 3.5.0 and xskytools_compact_app depends on xml ^3.6.0, flutter_test from sdk is forbidden.
So, because (appname) depends on flutter_test any from sdk, version solving failed.